分享一个通达信主图指标公式(标志性K线)

发布时间:2021-06-17 发表于话题:k线上1到9数字标记公式 点击:986 当前位置:酷财经网 > 娱乐 > 分享一个通达信主图指标公式(标志性K线) 手机阅读

这个是通达信主图指标,手机已测,电脑大家自己试试

主图指标源码:

影响时长:=60;

实体涨跌幅:=(MAX(CLOSE,OPEN)/MIN(CLOSE,OPEN)-1)*100,NODRAW;

标志性K线:IFF(实体涨跌幅==HHV(实体涨跌幅,影响时长),1,0),NODRAW,COLORYELLOW;

影响时间:=BARSLAST(标志性K线)+1,NODRAW;

上轨:IFF(BETWEEN(影响时间,1,影响时长),REF(HIGH,影响时间-1),DRAWNULL),NODRAW,COLORRED;

下轨:IFF(BETWEEN(影响时间,1,影响时长),REF(LOW ,影响时间-1),DRAWNULL),NODRAW,COLORGREEN;

冗余过滤:=BETWEEN(影响时间,2,59),NODRAW;

STICKLINE(上轨,上轨,上轨,12,0),COLORRED;

STICKLINE(下轨,下轨,下轨,12,0),COLORGREEN;

STICKLINE(标志性K线 AND CLOSE>OPEN,CLOSE,OPEN,8,0),COLORRED;

STICKLINE(标志性K线 AND CLOSEREF(OPEN,影响时间-1);

A_2:=COUNT(A_1,影响时间)==1 AND A_1;

一飞冲天:IFF(A_2 AND 影响时间!=1 AND 冗余过滤,1,DRAWNULL),NODRAW,COLORRED;

STICKLINE(一飞冲天,CLOSE,OPEN,8,0),COLORRED;

STICKLINE(一飞冲天,HIGH,LOW,0,0),COLORRED;

DRAWTEXT(一飞冲天,LOW,'B'),COLORYELLOW;

B_1:=CROSS(CLOSE,上轨) AND REF(CLOSE,影响时间-1)>REF(OPEN,影响时间-1);

B_2:=COUNT(B_1,影响时间)==2 AND B_1;

回首惊天:IFF(B_2 AND 影响时间!=1 AND 冗余过滤,1,DRAWNULL),NODRAW,COLORYELLOW;

STICKLINE(回首惊天,CLOSE,OPEN,8,0),COLORYELLOW;

STICKLINE(回首惊天,HIGH,LOW,0,0),COLORYELLOW;

DRAWTEXT(回首惊天,LOW,'B'),COLORMAGENTA;

C_1:=CROSS(CLOSE,下轨) AND REF(CLOSE,影响时间-1)>REF(OPEN,影响时间-1) AND COUNT(回首惊天,影响时间)==0;

C_2:=COUNT(C_1,影响时间)==1 AND C_1;

蓄势擎天:IFF(C_2 AND 影响时间!=1 AND 冗余过滤,1,DRAWNULL),NODRAW,COLORMAGENTA;

STICKLINE(蓄势擎天,CLOSE,OPEN,8,0),COLORMAGENTA;

STICKLINE(蓄势擎天,HIGH,LOW,0,0),COLORMAGENTA;

DRAWTEXT(蓄势擎天,LOW,'B'),COLORYELLOW;

D_1:=CROSS(下轨,CLOSE) AND REF(CLOSE,影响时间-1)

本文来源:https://www.kucaijing.com/articles/47962.html

标签组:[通达信指标公式

相关APP下载

扩展阅读文章

热门话题

娱乐推荐文章

娱乐热门文章